Window Management

CODE V contains a number of different types of data and specialized calculations. It therefore often presents you with a number of windows to manage. This section discusses various issues related to windows in CODE V.

The Window Navigation Bar

This is your main tool for keeping track of many windows. Whether a window is hidden by other windows or even minimized (shrunk to only its title bar), the Navigation bar will let you see what you have and bring any window to the front. It uses an outline format to hide or show objects of a particular type, such as Listings or Analysis Windows (a plus sign indicates that there are collapsed or hidden items—click the plus or minus sign to expand or collapse the heading). The Window Navigation Bar is “docked” along the left side of the main window by default. You can dock it to another position or allow it float, dragging it to the desired position with the mouse (Tip: Use the control key while dragging to prevent docking when near an edge).

Graphical Windows - Number, Sizes, and Positions

Operations started from the menu bar or toolbar will normally create special Tabbed Output Windows (TOWs) for their outputs, and there is no limit on the number of such windows you may have open. If you use the Command Window to enter commands that produce graphics, or if you run macros that produce graphics, graphical output are displayed in special non-TOW graphical windows. You can set the number, sizes, and positions of graphical windows, but only with the special WND commands, such as WND OPE 5 (allow 5 graphical windows). For more information about these commands, type WND\ (WND followed by a backslash character) on the command line in the Command Window. Help text for the WND command will then be displayed in the Command Window.
Graphical Windows - Special Controls

Each graphical window has a special set of icon controls along the top. These are used to zoom in or out and to add simple annotation (lines and text blocks) to a plot. You can also save plots from this special toolbar.

Tear-Off Windows

Tabbed Output Window (TOWs) have tabbed pages containing text and often one or more plots. These containers also update whenever you click the Execute button, shown below.

What if you don't want to update some of the data? For example, you may want to save a result to compare with a later result. Tear-off windows allow this. Just grab the tab with the mouse (pressing the left mouse button) and drag. This makes a non-updating copy of the plot or text data. Tear-offs are demonstrated in the first session of this Test Drive.

Saving Information: Lenses, Files, Favorites

In addition to saving lens data (File > Save Lens As menu), you can also save the contents of the various windows text or graphics window. Just bring the window to the front and select File > Save Window As. Since TOWs typically contain multiple outputs (text and/or graphics), you need to tear off the desired tab before saving it.

You can also create a database of your own favorite lenses, to serve as starting points for future designs. When you have a lens you want to keep as a favorite, first save it in any directory (create a “favorites” directory or keep it in your regular directory). Then choose Tools > Add to favorites and enter a comment about the lens. This lens (including a picture) will be available next time you run the New Lens Wizard and select My Favorites as the starting point for your new lens.
Starting, Stopping, and Contacting ORA

Installing CODE V

We assume that CODE V has already been properly installed. For help with this, please see the installation guide that came with your CODE V installation CD-ROM. Also make sure that your security key is attached, if one is required for your CODE V installation. If you have problems, see “Contacting ORA” on page 13.

Starting CODE V

To start CODE V on PC, simply use the Start menu to locate the program shortcut (or double-click the desktop shortcut if you’ve kept it). To start CODE V on a Sun workstation, launch the Windows emulation tool that is supplied with CODE V, and launch CODE V from the Start menu there.

Saving Your Work

To save a lens file, choose the File > Save Lens As menu.

To save the contents of a text or graphics window, bring it to the front and choose the File > Save Window As menu.

To save the settings you have entered for a CODE V option, click the Option Set button on the lower left corner of the option dialog box. This displays the Option Sets dialog box. Click the Save As button in the Option Sets dialog box and enter a descriptive name for the settings you have entered.

Exit from CODE V

Choose the File > Exit menu to exit from CODE V.

Contacting ORA

You can contact ORA to request technical assistance in several ways:

Email: service@opticalres.com
Web: http://www.opticalres.com
Telephone: (626) 795-9101
Before You Begin: Settings Assumed for this Manual

CODE V is designed with a number of configurable settings that can affect how the program looks and behaves. Many of these settings are mainly cosmetic or personal preferences (e.g., font sizes), but some can lead to confusion if they are different from what is assumed here. Before you start the following test drive sessions, do the following.

1. Choose the **Tools > Preferences** menu.
2. In the **Preferences** dialog box, click the **General** tab.
3. Check and set if needed (other settings don’t matter for this manual):
   - System units set to **Millimeters**
   - Aperture mode set to **Semi** (displays aperture radii rather than diameters)
4. Click the **UI** tab (for user interface settings; see example below).
5. Check and set if needed (other settings don’t matter for this manual):
   - Under **UI Simplification**, select **Single Configuration (Zoom)**.
   - Under **Settings Activation**, select **Invoke Options Settings First**.
   - Under **Use Wizards**, select **New Lens**.
6. Choose the **Edit > Radius Mode** menu to set the radius/curvature mode.
7. Click **OK** to save these settings (other settings and tabs are not important for these examples).

![Preferences Dialog Box](image-url)
Session 1
A Few Quick Clicks

In this first session, you will take a Cooke triplet lens, change it from f/4.5 to f/3, and optimize it to work as well as possible in his new configuration. This will only take a few quick clicks, but it will demonstrate some of the major features of CODE V's user interface, including menus, dialog boxes, toolbars, and spreadsheets.

Contents

Starting with an Existing Lens .................................................................16
Analyze the Starting Point .....................................................................20
Optimize This Lens ..............................................................................23
Analysis and Comparison ....................................................................30
Starting with an Existing Lens

The Cooke Triplet

The Cooke Triplet can be used as a simple photographic objective. It’s a common example in lens design courses and a good starting point for your work with CODE V. It has three elements, with the aperture stop on the front surface of the second element. This version is one of the sample lenses supplied with CODE V and covers a semi-field of view of 20 degrees with an f/number of 4.5 (the lens is set up with three pre-defined fields for analysis purposes, 0 degrees or “on-axis,” 14 degrees, and 20 degrees).

Starting Out

To start out, open the CODE V file cooke1.len which is found in the lens folder within the CODE V installation directory (usually C:\CODEV9000).

- Choose the File > Open... menu, browse to the lens folder, and open the file cooke1.len
The Lens Data Manager Spreadsheet

The Lens Data Manager (LDM) spreadsheet is the basic numerical view of your lens data. You can view and change the most common lens data (radius of curvature, thickness, glass) and easily access all the other data for your lens. This window is always open. Many operations will begin by selecting one or more cells or rows of this spreadsheet to identify items you wish to modify. You can left-click on cells to edit values. You can also double-click either to select an item or to display a drop-down list of items to choose from; for example, double-clicking on a cell in the Surface Type column displays a drop-down list of values.

You can also right-click on cells to produce a shortcut menu of commands that apply to that cell. Gray cells indicate data items you cannot directly modify, because they are calculated by the program. You can still right-click on gray cells, and the shortcut menu will provide ways to change the state of the particular data value.

![Lens Data Manager Spreadsheet]

Change the f/number

The first thing you will do is change the f/number (pupil specification) of the lens from 4.5 to 3.0. Expanding the pupil like this will cause some aperture and aberration problems, but CODE V will later fix these problems very easily.

1. Click the Pupil Specification button:

![Pupil Specification button]

This is found on the System Data toolbar:
If you do not have the System Data toolbar displayed, you can access the pupil specification data by choosing the **Lens > System Data** menu, and then clicking **Pupil** in the **System Data** window.

2. Highlight the value of **4.5** with the mouse and type **3.0**.

3. Click the **Commit Changes** button to send this modified data to CODE V’s lens database. Note that depending on your window and screen size, you may have to scroll or resize your CODE V main window to see this button in the lower left corner of the System Data window.

Since the Pupil Specification is already **Image F/Number**, you can simply enter the new f/number. If you wanted to change to a different pupil definition, you could choose it from the drop-down list.

4. Optional: If you would like to change the title of the lens to reflect the fact that its f/number is now 3, click **System Settings** in the navigation tree in the **System Data** window. You will see the lens title at the top of the System Settings page. Change f/4.5 to f/3 and click the **Commit Changes** button.

5. You can now close the System Data window by clicking the appropriate control in the upper right corner (click the X).
Look at a Picture

A lens picture will show you what has happened to the lens as a result of this change. There are a number of ways to make lens pictures in CODE V. For this example, you can just use a quick 2D lens drawing. CODE V has a number of special single-click "quick" commands for common operations. These are identified by the stylized "Q" in the upper left of the icon, and they generally produce a plot or text output based on default or commonly used settings (you will later learn how to use the non-quick versions of these commands, with dialog boxes that allow you to change many settings). The Quick 2D Lens Drawing tool looks like this as a large icon:

With small icons, it looks like this on its default toolbar:

This will make a labeled lens drawing like the one below. You can zoom in with the magnifying glass icon to show the problem with element edge thicknesses. The program can't make the positive elements big enough to pass the light when the lens is opened to f/3, although it still shows the path the rays would take if traced through these "virtual edges." When you optimize the lens, you will have CODE V fix these edges automatically.
Analyze the Starting Point

Ready to Compare

Before you start to improve the triplet you have just modified, you want to analyze its performance and get ready to compare the before and after results. CODE V analysis options (including the "quick draw" feature you have just used to see a picture of the lens) use special output windows that can be updated when the lens is changed. If you want to save a result from one of these options for later comparison, you can simply “tear off” the tab containing the graphic or text you wish to save. This really just makes a copy of the output that is not updated.

- Use the mouse to drag the plot tab (labeled 1) of the lens picture you just made. Place and size the torn-off plot as desired for later use.

Note that you can optionally use the File > Save Window As menu to save a copy of the graphic to your disk. The file name on the window’s title bar can help you keep track of multiple graphics you may save.
Ray Trace Results

Ray aberration curves are plots of transverse ray aberrations (ray position errors) for all defined wavelengths as a function of ray height in the entrance pupil. This is a quick way to see if the lens is forming a good image, since for a perfect image, rays from a single object point would focus at the same point for all heights in the entrance pupil is (zero aberration). Let’s see what the f/3 triplet can do, using another quick toolbar command.

1. Click the quick ray aberration plot icon:

This produces the following plot. In this example, the plot has been zoomed in on to see the detail for the on-axis field position. You can see from this plot, which is auto-scaled to the size of the aberration, that there is substantial aberration when you open up a lens from its design f/number to a wider aperture (f/4.5 to f/3 in this case).

2. Left-click on the 1 tab at the bottom of the plot and drag it to tear off a copy.

You will want to save this to compare to your optimized lens.
You can also look at a quick spot diagram. A spot diagram shows the plotted
distribution of a set of rays from each field or object point defined in the lens
(this session uses a rectangular grid of rays evenly spaced on the entrance
pupil, with rays traced in all the defined wavelengths, allowing you to see
chromatic aberration).

3. Click the quick spot diagram toolbar button:

4. To allow later comparison, left-click on the 1 tab at the bottom of the plot and
drag it to tear off a copy, as you did for the ray aberration plot above. The torn-
off copy is shown below (it has been saved in a file with the File > Save
Window As menu and zoomed in on the on-axis field point to show how
scattered the rays are due to aberration).

Note that the scale bar in the lower right corner—its length is 0.0875 mm. This
scale factor was set automatically by CODE V based on the size of the
aberration. When you optimize this lens, you will use the Spot Diagram option
and set the scale factor to this value for comparison with the torn-off plot.