Test Drive

CODE V 9.0
September 2001

OPTICAL RESEARCH ASSOCIATES
3280 East Foothill Boulevard, Suite 300
Pasadena, California 91107 USA
Tel: (626) 795-9101
Fax: (626) 795-0184
E-mail: service@opticalres.com
WWW: http://www.opticalres.com
The information in this document is subject to change without notice and should not be construed as a commitment by Optical Research Associates (ORA®). ORA assumes no liability for any errors that may appear in this document.
The software described in this document is furnished under license and may be used or copied only in accordance with the terms of such license. CODE V output listed and plotted may vary version to version, platform to platform.

CODE V Test Drive

Principal Author:
Bruce R. Irving

Production Staff:
Rosemary Coblentz
Laura Mickens
Susan Montepio

Copyright © 2001 by Optical Research Associates.
All rights reserved.

Proprietary Software Notification

CODE V® is the proprietary and confidential property of ORA and/or its suppliers. It is licensed for use on the designated equipment on which it was originally installed and cannot be modified, duplicated, or copied in any form without prior written consent of ORA. If supplied under a U.S. Government contract the following also applies:

Restricted Rights Legend

Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or in subparagraph (c) of the Commercial Computer Software - Restricted Rights clause at FARs 52.227-19.

ORA, CODE V, LightTools, and Global Synthesis are registered trademarks and Macro-PLUS and Worksheet Buffer are trademarks of Optical Research Associates. Other trademarks or marks are the property of their respective companies.
Contents

Introduction ............................................................................................................. 1

CODE V User Interface ............................................................................................. 3
   Interface Elements ................................................................................................. 4
   The CODE V Window ............................................................................................. 4
   Windows Standard Features .................................................................................. 5
   Menus, Dialogs, Spreadsheets, and Commands ................................................... 6
   Undo ....................................................................................................................... 6
   New Lens Wizard .................................................................................................. 6
   Toolbars and Quick Commands ............................................................................ 6
   Surface Properties and System Data Windows ..................................................... 7
   Tabbed Output Windows ......................................................................................... 8
   Command Window Features ................................................................................. 8
   Review Spreadsheets ............................................................................................. 9
   Macros ................................................................................................................... 9
   Status Bar ............................................................................................................ 9
   “What’s This?” and Other Help ............................................................................. 10

Window Management ............................................................................................... 11
   The Window Navigation Bar ................................................................................. 11
   Graphical Windows - Number, Sizes, and Positions ............................................ 11
   Graphical Windows - Special Controls ................................................................. 12
   Tear-Off Windows ............................................................................................... 12
   Saving Information: Lenses, Files, Favorites ....................................................... 12

Starting, Stopping, and Contacting ORA ................................................................ 13
   Installing CODE V ............................................................................................... 13
   Starting CODE V .................................................................................................. 13
   Saving Your Work ................................................................................................. 13
   Exit from CODE V ............................................................................................... 13
   Contacting ORA ................................................................................................ 13

Before You Begin: Settings Assumed for this Manual ........................................... 14
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Session 1: A Few Quick Clicks</td>
<td>15</td>
</tr>
<tr>
<td>Starting with an Existing Lens</td>
<td>16</td>
</tr>
<tr>
<td>The Cooke Triplet</td>
<td>16</td>
</tr>
<tr>
<td>Starting Out</td>
<td>16</td>
</tr>
<tr>
<td>The Lens Data Manager Spreadsheet</td>
<td>17</td>
</tr>
<tr>
<td>Change the f/number</td>
<td>17</td>
</tr>
<tr>
<td>Look at a Picture</td>
<td>19</td>
</tr>
<tr>
<td>Analyze the Starting Point</td>
<td>20</td>
</tr>
<tr>
<td>Ready to Compare</td>
<td>20</td>
</tr>
<tr>
<td>Ray Trace Results</td>
<td>21</td>
</tr>
<tr>
<td>Optimize This Lens</td>
<td>23</td>
</tr>
<tr>
<td>Optimization</td>
<td>23</td>
</tr>
<tr>
<td>Setting Default Variables</td>
<td>23</td>
</tr>
<tr>
<td>Add Thickness Variables</td>
<td>24</td>
</tr>
<tr>
<td>Running AUTO for Optimization</td>
<td>24</td>
</tr>
<tr>
<td>Analysis and Comparison</td>
<td>30</td>
</tr>
<tr>
<td>Before and After Comparison</td>
<td>30</td>
</tr>
<tr>
<td>Ray Aberration Curves</td>
<td>30</td>
</tr>
<tr>
<td>Spot Diagram</td>
<td>31</td>
</tr>
<tr>
<td>Save Your Work</td>
<td>32</td>
</tr>
<tr>
<td>Exit or Continue?</td>
<td>33</td>
</tr>
<tr>
<td>Session 2: Starting from Scratch</td>
<td>35</td>
</tr>
<tr>
<td>Setting Up a New Lens System</td>
<td>36</td>
</tr>
<tr>
<td>Cassegrain f/10</td>
<td>36</td>
</tr>
<tr>
<td>Types of Data</td>
<td>36</td>
</tr>
<tr>
<td>The New Lens Wizard</td>
<td>37</td>
</tr>
<tr>
<td>Starting Out</td>
<td>37</td>
</tr>
<tr>
<td>Starting Points</td>
<td>38</td>
</tr>
<tr>
<td>Basic System Data</td>
<td>38</td>
</tr>
<tr>
<td>Surface Data</td>
<td>42</td>
</tr>
<tr>
<td>Create a Surface</td>
<td>42</td>
</tr>
<tr>
<td>Define Basic Surface Data</td>
<td>43</td>
</tr>
<tr>
<td>System Data Changes</td>
<td>45</td>
</tr>
<tr>
<td>Surface Apertures</td>
<td>46</td>
</tr>
<tr>
<td>Save and Analyze</td>
<td>48</td>
</tr>
<tr>
<td>Optimize</td>
<td>49</td>
</tr>
<tr>
<td>Non-Spherical Surfaces</td>
<td>49</td>
</tr>
<tr>
<td>Other Variables</td>
<td>50</td>
</tr>
<tr>
<td>Running AUTO</td>
<td>51</td>
</tr>
<tr>
<td>Saving Inputs for AUTO and Other Options</td>
<td>52</td>
</tr>
</tbody>
</table>
Inserting a Fold Mirror ........................................................................55
Adding a Tilted Surface ......................................................................55
Add Thickness to the Mirrors ..............................................................56
Diffraction Analysis (PSF) ................................................................58
Commands and Macros .......................................................................61
    The Command Window ..................................................................61
    Running a Macro ...........................................................................62
Summary for New Lenses ....................................................................65

Index ..................................................................................................67
Introduction

Thank you for trying CODE V ("code five") from Optical Research Associates. We are sure you will find the program easy to learn and use, as well as extremely powerful and flexible for all your optical design and analysis needs.

This Test Drive is designed to acquaint you with a few of CODE V’s basic capabilities for optical modeling, analysis, and optimization. CODE V can be used to model optical systems for a wide range of imaging, photonics, and non-imaging applications. Because of this flexibility, CODE V has a large number of features, only a subset of which are typically used for any one application. We have tried to make these features as easy as possible to learn and use, by providing a user interface similar to many common Windows applications. If you have used applications such as Microsoft® Excel, you will find the menus, spreadsheets, windows, dialog boxes, and other interface features to be quite familiar. We have provided ways to customize the user interface, and beyond this, CODE V also includes a powerful command language and macro programming facility.

This Test Drive describes two independent sample sessions with CODE V, each designed to be completed at a single sitting. The first uses a pre-supplied lens model and just a few easy steps to modify, optimize, and analyze a simple photographic-type lens. This shows how much can be done with CODE V with very little input and just a few mouse clicks. It should take about 10 or 15 minutes to complete.

The second session is a bit longer. It leads you through the process of entering a completely new optical system model, defining variables, optimizing it, and doing some diffraction-based image analysis. This session should take 30 minutes or less.
When you have completed these two sample sessions, you will have a good idea of how CODE V is used to solve simple or sophisticated optical problems. These two systems have only a few optical surfaces, but CODE V can handle systems of over 900 optical surfaces with many unusual optical properties, and the techniques are just the same as those used in this small manual (the same types of steps, just a lot more of them).

At the start of this Test Drive is a brief section that describes the features of CODE V's user interface. We strongly urge you to read this section before trying the examples. Knowing the assumptions and techniques of the user interface will make your later use simpler and more productive.

If this is your first experience with CODE V, we hope it is an interesting and pleasant one for you. We'd like to hear your comments on the program and its documentation; we are always working to improve our product to make it a better tool for all our customers' needs.
CODE V User Interface

In the following pages, the main CODE V interface features are illustrated and discussed. This section will acquaint you with these features and help you quickly become productive in the program. If you are familiar with Windows, you will already feel comfortable with many aspects of the CODE V interface.

Contents

Interface Elements........................................................................................................4
Window Management .....................................................................................................11
Starting, Stopping, and Contacting ORA.................................................................13
Before You Begin: Settings Assumed for this Manual ..............................................14
Interface Elements

The CODE V Window

Like most Windows-based applications, CODE V runs in a main “parent window” that contains various other windows and controls. With few exceptions, all of the windows and other elements can be moved, resized, and customized to suit your needs and tastes.

- **Lens file name** - File name for your current lens “document.”
- **Window Navigation Bar** - Provides a way to keep track of all the windows you are working with. This Navigation bar can be “docked” along an edge of the CODE V window, or it can float, as shown here (hold down control key to prevent docking while dragging with mouse).
- **Menu bar** - Contains most of the functions of the program. You can add additional menu items (such as frequently used macros) with the **Tools - Customize** dialog.

- **Toolbar** - Single-click shortcuts for many common functions. Place the mouse pointer over a tool to see a descriptive “tool tip” message. You can move toolbars around by dragging them with the mouse. You can also modify toolbar contents with the **Tools - Customize** dialog.

- **Lens Data Manager (LDM) Window** - This spreadsheet is the main numerical view of the primary lens data. You can access other data and operations by right-clicking on cells, rows, or columns of this spreadsheet. The pop-up menu will contain only the commands you can enter for the item you clicked.

- **Command window** - The “journal” window for all text-based output, and the main workspace for entering and viewing results of commands.

- **Command entry line** - Part of the Command Window, this is the place to type program commands if you wish to use them (commands and mouse-based operations are integrated in CODE V - you can use either method at any time).

- **Plot Windows** - Graphics that are generated by command operations or by macros are created in dedicated “plot windows.” You can have up to 100 such windows, although 3 or 4 is more common.

- **Tabbed Output Window** - Specialized calculations such as MTF and spot diagrams are called “options” in CODE V. When launched from the menu bar, each option has its own “tabbed output window” (TOW). TOW’s have many special and useful properties that are discussed in the next section, Special Interface Features.

### Windows Standard Features

If you are familiar with other Windows-based applications such as Microsoft Excel, you will find the basic operation of CODE V to be quite familiar. Operations such as moving and resizing windows, editing spreadsheets, selecting items (text, numbers, rows, columns), copying and pasting, etc. follow normal practices of other Windows applications. Most of these operations use the left mouse button, but as in many other programs, the right mouse button is used to display shortcut menus based on your current situation.

Although standards are followed to a great extent, optical design is a specialized application, so there are a number of special features of the interface that are specific to CODE V. Most of them are covered in this section, as well as some “standard” features that are useful to know about in more detail, such as Undo, the status bar, and toolbar commands.
Menus, Dialogs, Spreadsheets, and Commands

CODE V’s user interface allows you to use mouse-based graphical interface methods including menus, toolbars, dialog boxes, and spreadsheets, similar to other modern Windows-based products. It also has a complete command language for frequent or experienced users who wish to learn the commands.

The two method of input co-exist in the program -- to use commands, you simply go to the Command Window and start typing. There is no real distinction between commands and menu-based actions. When you change data in a spreadsheet or dialog, you will see the resulting commands in the Command Window. If you type commands, spreadsheets or dialogs will update to reflect the changes. Note, however, that graphic windows and Tabbed Output Windows do NOT automatically update when the lens is changed. You need to click the “execute” button on the window to update it.

Undo

The Undo facility (Edit > Undo menu) keeps track of virtually all changes that you make, allowing you to track down and correct many mistakes. Actions that do not change lens data (such as running an option to calculate and display something) are generally not undoable. The toolbar icons for Undo and Redo also contain scrolling lists of all the commands that have been performed and are available for undo or redo.

New Lens Wizard

The New Lens Wizard (File > New menu) prompts you through the steps needed to create a new lens model, based on existing lens data from any of several sources, or starting from scratch. The second session in this Test Drive, “Starting From Scratch,” demonstrates the use of the New Lens Wizard.

Toolbars and Quick Commands

Toolbars provide single-click access to frequently used operations. Tooltips are supported to help you learn the functions of the various icons (hold the mouse over a toolbar icon and a small text message will appear). Some toolbar icons are called “quick commands,” and are identifiable by a stylized letter Q. These toolbar icons
will produce an immediate result, such as a lens picture or analysis graphic based on default settings. Toolbars can be customized in the Customize dialog box (Tools > Customize menu).

Surface Properties and System Data Windows

The Surface Properties window (Lens > Surface Properties menu) provides centralized access to all the many types of data that can be attached to each surface of a lens model. It uses a tree-structure “outline” to switch between multiple pages containing the various categories of surface data. The System Data window (Lens > System Data menu) is similar, providing a centralized place for viewing and changing all system-level data for the lens model. System data is anything that applies to the system as a whole (wavelengths, pupil size, lens title, etc., as well as various advanced properties such as input polarization states).

While the Surface Properties and System Data windows are open, you can select menus and move to other windows. There is no OK button, because changes made in any input field are sent to the CODE V database as soon as the cursor leaves that field. This is called “committing” the changes. There is a Commit Changes button that is useful when you want to make a single change on a page of the dialog. This button will only be available while there are uncommitted changes (otherwise it is dimmed out).
Tabbed Output Windows

Specialized calculations such as MTF, spot diagrams, and AUTO (automatic design optimization) are called “options” in CODE V. When launched from the menu bar, each option has its own “tabbed output window” (TOW). This window remembers the settings used to create the data and has separate tabbed pages for text output, multiple graphics, and error messages. If the lens data is changed, a TOW can be updated with a single click (execute button). You can also change the settings and re-run the output in the same TOW.

Tip: If you need to compare output with different settings, you can open up additional copies of the TOW for the same option. Just run the option again from the menu bar, and a new copy will be created.

Command Window Features

The Command Window has an outline structure, allowing you to “collapse” sections of output and display only the commands that generated the output. This makes it easier to find previous outputs. You can also split the output window into two separately scrolling panes (the split control is the small bar at the top of the scroll bar). When you type commands, the command window remembers all the commands you have entered. You can use the up and down arrow keys to recall previous commands for editing or re-running. There is a control to display the entire history as a scrolling list, and a Clear Text button to delete text from the window. Use of commands is covered briefly at the end of the second session in this Test Drive.
Review Spreadsheets

Review spreadsheets provide a convenient format for viewing and modifying all data of a particular category, such as surface apertures or decentered data. Review spreadsheets are found under the Review menu.

Macros

CODE V has a command-based macro language that is extremely powerful and general. Although you can use this language to write your own custom macros, many users first make use of the various ORA-supplied macros that add special capabilities to CODE V. You can view and run available macros from the Tools > Macro menu.

Status Bar

The lower border of the main CODE V window is called the status bar. Here you can display a number of items such as lens title, focal length, system units, etc. These items will update whenever they are changed. You can set the contents of the status bar by choosing the Tools > Customize menu, then clicking the Status Bar tab.
“What’s This?” and Other Help

CODE V has extensive help capabilities, including “What’s This?” help. When you choose the Help > What’s This? Help menu, the cursor changes to a question mark. When you click this on most interface objects, a pop-up description will appear. There is also extensive how-to help (available from the Help > Contents and Index menu) and a complete online reference manual.