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1. Purpose

 

The objective of this project is to 

 

perform the basic steps in digital VLSI design from RTL-level HDL
speciÞcation up to design and veriÞcation of the Þnal physical layout.

 

SpeciÞcs: You will design the system shown in Figure 1 that implements a 16-bit adder summing
up the outputs of two pseudo-random number generators. To accomplish this, we will be follow-
ing the following steps (Note that this is just a basic digital design ßow. Commercial design ßows
will include more steps for reasons ranging from increased functionality, better performance, bet-
ter testability, etc.):

 

¥

 

Verilog design and veriÞcation (result: veriÞed Verilog code)

 

¥

 

Logic Synthesis (result: gate-level netlist in Verilog format)

 

¥

 

Post-synthesis veriÞcation (result: veriÞed gate-level netlist in Verilog format)

 

¥

 

Placement and routing of individual modules (result: physical layout of the individual modules)

 

¥

 

DRC, LVS and SPICE veriÞcation of individual modules (result: veriÞed physical layout of
individual modules)

 

¥

 

Schematic design and veriÞcation of top-level module (result: veriÞed schematic of the top-level
design)

 

¥

 

Placement and Routing of the top-level design (result: Physical layout of the top-level design)

 

¥

 

DRC, LVS and SPICE veriÞcation of top-level design (result: veriÞed physical layout of the
entire design)

 

¥

 

Done!

 

2. Verilog Design and VeriÞcation

 

1. Download the Þles Ôadder16.vÕ, Ôlfsr16.vÕ and Ôproj4_test.vÕ and copy them into your working direc-
tory (i.e. /homes/<username>/enee302). The Þle Ôproj4_test.vÕ is a testbench that instantiates three 
modules, two each of the random number generator (Ôlfsr16.vÕ) and one adder, connected as shown in 
Figure 1.

 

Random Number Generator Random Number Generator

16-bit Adder

addend1[15:0] addend2[15:0]

out_sum[15:0]

 

Figure 1:  Bloc k dia gram of the cir cuit to be designed f or pr oject 4 sho wing a 16-bit ad der summing up the outputs of tw o 
pseudo-random n umber g enerator s. These pseudo-random g enerator s are implemented using linear -feedbac k shift reg-
ister s (LFSRs).    
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2. Do the verilog simulation by executing the script Ô/software/cadence/cadence ldvÕ and then typing 
Ôncverilog proj4_test.v lfsr16.v adder16.vÕ. You should now see a stream of numbers of the form 
Ò<num1> + <num2> = <num3> Correct result: <num4> (<num5> + <num6> = <num7>)Ó. Here, the 
Þrst three numbers are the outputs of the different verilog modules, and the fourth number uses ver-
ilogÕs arithmetic capabilities to compute the sum of the Þrst two numbers (which is the reason itÕs 
labeled as the correct result). The last three numbers show the hexadecimal values of the correspond-
ing signals. A cursory examination of the outputs should show that everything is correct (since it was 
already veriÞed before being distributed to the class).

3. At this point, we now have the working RTL Verilog speciÞcation of our application. 

 

3. Logic Synthesis 
(result:  gate-le vel netlist in Verilog f ormat)

 

1. The next step in the process is to perform logic synthesis to transform the high-level RTL Verilog 
description into a gate-level netlist. For this class, you will be given a script that will allow the synthe-
sis tool to complete the whole synthesis process without any further user input (all necessary user 
inputs being included in the script). This accomplishes what we require, but hides a whole lot of things 
from the user.

2. For this class, we will be using Synopsys Design Compiler as our synthesis tool. Additionally, we will 
be using a technology-dependent library to transform the RTL verilog into a gate-level netlist that uses 
gates or standard cells that are designed for the TSMC 0.25um process.

3. The compile script that we will provide to Synopsys is Ôcompile.scrÕ and should already be in your 
working directory. This is a very simple script that tries to minimize the area usage of the resulting 
gate-level circuit. This script barely scratches the surface of what logic synthesis can do, but is sufÞ-
cient for our initial foray into digital design.

4. Our desired outputs are separate gate-level netlists of our two modules (the adder and the rand.num. 
generator). That means we have to run logic synthesis twice -- once for each design. Normally, individ-
ual modules can be included in a higher-level design and then ßattened so that the output is a single, 
ÒßatÓ netlist. We could easily do this, but one of the goals of the project is to give you experience on 
performing hierarchical design.

5. To use Synopsys in the glue system, type Ôtap synopsysÕ Þrst. Then, you need to modify the com-
pile.scr to tell it which Þles to use and to output. SpeciÞcally, you need to change all occurrences of the 
string ÔENEE302_FILEÕ to either Ôlfsr16Õ or Ôadder16Õ depending on which Þle you are going to syn-
thesize. You can do this by using any text editor, or by using the sed command Ôsed 
Ôs/ENEE302_FILE/lfsr16/gÕ compile.scr > compile_new1.scrÕ. This uses the sed string editor to auto-
matically do a search and replace of all ÔENEE302_FILEÕ strings (including, unfortunately, a line in 
the comment, but this doesnÕt really matter).

6. After generating the new Þle Ôcompile_new1.scrÕ, proceed with synthesis by invoking the command 
line version of Synopsys Design Compiler: Ôdc_shell -f compile_new1.scrÕ.

7. After the synthesis tool is Þnished, the main output Þle we are interested in is the one with the exten-
sion *.vh. If you were synthesizing the Þle Ôlfsr16.vÕ, the output gate-level netlist should be named 
Ôlfsr16.vhÕ. The *.vh extension is just a convention used by this speciÞc standard-cell library to indi-
cate a gate-level netlist Verilog Þle (as opposed to an RTL Verilog). Viewing the Þle (i.e. by doing 
Ômore lfsr16.vhÕ) should show you a structural Verilog Þle with a list of standard cells connected 
together by wires.

8. Repeat synthesis for the second Þle.

9. At this point, you should now have the gate-level version of your design inside the Þles Ôlfsr16.vhÕ and 
Ôadder16.vhÕ.
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4. Post-synthesis veriÞ cation 
(result:  veriÞed gate-le vel netlist in Verilog f ormat)

 

1. In a perfect world (or at least, in a world with perfect CAD tools), the gate-level netlists weÕve gener-
ated should be perfect and ready to be used for physical layout. But sometimes, CAD tools do fail to 
meet our requirements, and it is imperative that we verify whether the result still follows our speciÞca-
tions. For this project, we will perform veriÞcation of the gate-level netlist by re-executing the Verilog 
testbench used for the RTL version and comparing the results. (This will sufÞce for our application, 
but a commercial design ßow will probably use more intensive veriÞcation of the netlist, speciÞcally a 
step called Formal VeriÞcation where a set of rules and equations are used to formally establish an 
equivalence between the gate-level netlist and the higher-level RTL speciÞcation)

2. To perform the veriÞcation, invoke the script Ô/software/cadence/cadence ldvÕ the way you did before 
but this time, invoke the program ÔncverilogÕ and specify the gate-level netlists instead of the RTL: 
Ôncverilog proj4_test.v lfsr16.vh adder16.vhÕ.

3. Compare the output of this simulation with the previous one. Because these designs are still relatively 
simple, there is very little chance that the synthesis failed. Try manually modifying the gate-level 
netlists (by deÞning bogus wires and reconnecting some of the gates) and redo the simulation. You 
should now see differences in the result.

4. If youÕve modiÞed the gate-level netlist, revert them back to the original. At this point, we should have 
gate-level netlists in Verilog that are veriÞed to behave the same way as their RTL counterparts.

 

5. Placement and r outing of individual modules 
(result:  physical la yout of the individual modules)

 

1. Before proceeding, it is important to realize that after generating the veriÞed gate-level netlist, differ-
ent paths exist in the digital design ßow to perform physical layout. In our case, the speciÞc ßow we 
are trying to follow is for semi-custom ASIC design, and the next steps would be signiÞcantly different 
had we been aiming to implement our design on an FPGA, for example. Even with custom ASIC 
design in mind, the design ßow still branches into many paths depending on which set of CAD tools 
you are planning on using. This may be a bit confusing, so just keep in mind that the objective of creat-
ing a physical layout from a gate-level netlist is a pretty complicated process, and different companies 
provide different software suites to achieve the objective, and you might have to follow different steps 
in the design ßow for each of them. To complicate things a little more, companies like Cadence offer 
different suites of program that you can use to generate the physical layout given the gate-level netlist 
of the design (among them are the programs Silicon Ensemble, SOC Encounter, and Virtuoso).

2. To simplify things a little bit, we will only be using Silicon Ensemble and Virtuoso for our design ßow. 
As a background, Silicon Ensemble is great for standard-cell based designs, but is unwieldy to use for 
semi and full-custom design, especially with designs containing analog components. On the other 
hand, Virtuoso (and its enhanced version, Virtuoso-XL), excels at semi and full-custom design because 
it provides you with complete control over the physical aspects of your circuit. From experience, how-
ever, the standard-cell design capabilities of Virtuoso is lacking compared to that of Silicon Ensem-
bleÕs.

3. Given the above points, we can leverage the speciÞc strengths of both CAD programs by using Silicon 
Ensemble to generate the standard-cell layouts of individual modules, and then import these modules 
into Virtuoso for added processing and veriÞcation. In project 3, you were asked to clean up the layout 
of a Þbonacci counter and then perform veriÞcation of the design. This layout was generated by Silicon 
Ensemble and then imported into Virtuoso.

4. LetÕs now proceed to generating the layouts. Like what we did for logic synthesis, we will be providing 
a script to Silicon Ensemble such that the layout will be automatically generated given the instructions 
in the script. Before proceeding, we need to generate scripts that point to the proper gate-level netlist. 
The original script is named Ôseultra.scr.origÕ and should be in your working directory. 

5. Delete the Þle Ôseultra.scrÕ if it exists. Then, do another search and replace using sed to point Silicon 
Ensemble to the proper Þles: Ôsed Ôs/ENEE302_FILE/lfsr16/Õ seultra.scr.orig > seultra.scrÕ. 
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6. To enable the use of Silicon Ensemble, run the script Ô/software/cadence/cadence dsmseÕ. Run Silicon 
Ensemble by executing the following: Ôseultra -f seultra.scrÕ. This will take some time, and while it is 
running, you should see the outputs on the screen. For more complicated designs, this output should be 
analyzed to check whether fatal errors have occurred, but our designs are simple enough (and the 
restrictions very lax) that Silicon Ensemble shouldnÕt have any problem generating the layout.

Note: Running ©seultra -f seultra.scr© can give a "Pseudo color graphics card not detected" error. If 
so, use the shell Þle ©se_shell© that is provided.  First change the permission of the Þle using ©chmod 
+x se_shell©. Then, run ©se_shell -f seultra.scr© instead of ©seultra -f seultra.scr©.

7. The output of Silicon Ensemble is the Þle ÔÞnal.gds2Õ. This is a binary Þle that contains the description 
of your physical layout (i.e. all the layer shapes in your layout). As a side comment, this GDS II Þle is 
one of the Þle formats that you can use to submit your design to a chip foundry. 

8. The next step is to import this physical layout into icfb so that we could use it in Virtuoso. First, exe-
cute the script Ô/software/cadence/cadence ncsu50Õ. Among other things, it changes the PATH environ-
ment variable so that some programs that we need can be accessed. Next, do the actual import by 
executing Ôiitcells_se2icfbÕ. As can be guessed from the name of the script, this converts the output of 
Silicon Ensemble to a form usable in icfb. This should create a new directory in your working direc-
tory that contains the physical layout. Before we could use this fully in icfb, we will need to make sure 
that its deÞnition is included in the Þle Ôcds.libÕ. More on this step later.

Note: Before running ©iitcells_se2icfb©, you have to change an occurrence in the Þle of ©/samvr/© to 
©/your_username/©, where your_username is your real username.  This can be accomplished by 
manually editing the 1 occurrence in the Þle (line 12).

9. Repeat this procedure for the adder (you donÕt have to execute the scripts Ô/software/cadence/cadence 
???Õ since the environment modiÞcations are still active). First, remove the existing Ôseultra.scrÕ (the c-
shell default doesnÕt permit overwriting Þles by using shell redirection). Then generate another script 
that points to Ôadder16.vhÕ by doing Ôsed Ôs/ENEE302_FILE/adder16/Õ seultra.scr.orig > seultra.scrÕ. 

10. Run Silicon Ensemble by doing Ôseultra -f seultra.scrÕ.

11. Import the physical layout into icfb by doing Ôiitcells_se2icfbÕ, which should create a new directory 
called Ôadder16Õ in your working directory.

12. Now, the next step is to clean up these designs in Virtuoso (like what you did at the end of Project 3). 
But before proceeding, we need to make sure that icfb is aware of these designs. Check the Ôcds.libÕ 
Þle in your working directory and make sure that they include the lines ÔDEFINE adder16 
/homes/<username>/enee302/adder16Õ and ÔDEFINE lfsr16 /homes/<username>/enee302/lfsr16Õ. 
(The scripts youÕve executed before should have automatically inserted these lines, but sometimes they 
donÕt work. If your Ôcds.libÕ Þle doesnÕt have these lines, insert the lines manually)

13. If icfb is already running, go to View->Refresh in the Lib Manager window and click on ÔOKÕ. This 
should make the new designs visible in the Lib Manager window. If icfb isnÕt running, invoke it by 
executing Ôicfb &Õ. (IMPORTANT: Note that the next steps assume youÕve executed the script Ô/soft-
ware/cadence/cadence ncsu50Õ and Ô/software/cadence/cadence iccÕ in the current shell youÕre using). 

14. Clean up the two layouts you generated the same way you did for Project 3. Perform a DRC check and 
after your design is error-free, perform an extraction to generate the ÔextractedÕ cellview.

 

6. LVS and SPICE veriÞ cation of individual modules 
(result:  veriÞed ph ysical la yout of individual modules)

 

1. For the purpose of LVS checking, we now need to generate a schematic with which to compare the lay-
outs. In the icfb window, go to File->Import->Verilog. A window titled ÔVerilog InÕ should pop up like 
the one shown in Figure 2. For the Þrst Þeld (ÔTarget Library Name), enter Ôadder16Õ like shown in the 
Þgure. In the second Þeld, specify the IIT library as shown in the Þgure, and lastly, specify the actual 
Verilog Þle to import. Do this for both the adder and the lfsr designs. Click on OK. These should gen-
erate ÔschematicÕ and ÔsymbolÕ cellviews for the adder16 and lfsr16 libraries. 

If you Þnd Þgure 2 difÞcult to read, the values to enter into the "Verilog In" window are as follows:
Reference Libraries:  ©IIT_stdcells_tsmc025 sample basic© Verilog Files To Import:  
©/homes/your_username/ENEE302/adder16.vh©, or wherever adder16.vh is stored.
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2. Although the ÔsymbolÕ cellviews created during 
the previous steps are perfectly usable, they are a 
little cumbersome to use. We now replace these 
with alternative symbols. Locate the ÔsymbolÕ 
directory inside the adder16 and lfsr16 designs 
(i.e. 
/homes/samvr/enee302/adder16/adder16/sym-
bol) and delete them. One way to do this is the 
following: assuming the current directory is 
/homes/<username>/enee302/adder16/adder16, 
execute the command Ô/usr/bin/rm -rf symbolÕ. 
This should remove the ÔsymbolÕ directory and 
all the Þles and subdirectories inside it. Do this 
for the lfsr16 symbol directory also. Now, go 
back to your working directory (i.e. 
/homes/<username>/enee302) and untar the Þle 
Ôenee302_proj4_symbols.tarÕ by typing Ôtar -xvf 
enee302_proj4_symbols.tarÕ. This Þle contains 
alternative ÔsymbolÕ cellviews for both the lfsr16 
and adder16 designs and should automatically be 
extracted to the right directories. Go to Lib Man-
ager and click on View->Refresh to make sure 
that the new ÔsymbolÕ cellviews are active. 

3. Perform the steps for LVS checking the same 
way youÕve done previously.

4. After the design is LVS clean (i.e. it has passed 
the LVS check), generate its Ôanalog_extractedÕ 
cellview by clicking on ÔBuild AnalogÕ in the LVS window.

5. The SPICE veriÞcation of the individual modules are left off until the next step to save some time...

 

Figure 2:  Windo w used to impor t a Verilog netlist.  The main 
Þelds of interest are the Þ rst three , star ting fr om ÔTarget 
Librar y NameÕ.   

 

Figure 3:  Schematic cellvie w of the top-le vel design (correction to the Þ gure:  
the lo wer te xt label should sa y 16Õh1A94 instead of 16Õh1A54).   
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7. Schematic design and veriÞ cation of top-le vel module 
(result:  veriÞed sc hematic of the top-le vel design)

 

1. The next step is to create the top-level schematic for the entire design. This should look similar to the 
schematic shown in Figure 3. Create two instances of the lfsr16 module and one instance of the 
adder16 module. Connect the lfsr outputs to one of the adder inputs as shown in the Þgure. Instantiate 
a ÔvddÕ and ÔgndÕ symbol and then connect the signals ÔLOAD_VALÕ of each lfsr module to the proper 
supply rail depending on the desired initial ÒseedÓ value. For this project, initialize the Þrst lfsr to 
16ÕhAA00 and the second one to 16Õh1A94 as shown in the Þgure. Lastly, connect the signals 
LFSR_CLK and LFSR_RESET to input pins and create output pins for the adder outputs.

2. Click on ÔCheck and SaveÕ. When the design is free of errors, create a symbol by going to Design-
>Create Cellview->From Cellview. Accept all defaults. Save the symbol cellview then close its win-
dow.

3. The next step is to create a testbench so we could test the Þnal physical layout and also verify that the 
physical of each individual module is working. The easiest way to do this is to derive it from the test-
bench that was used for the Þbonacci counter. Open this testbench and then delete the Þbonacci 
counter symbol and replace it with the symbol for Ôproj4_ÞnalÕ. Connect capacitors to all of the mod-
ule outputs. Finally, we need to make the input signals slower because the default adder topology gen-
erated during synthesis is a slow ripple-carry adder. Change the Pulse Width and Period of the clk 
signal to 5n and 10n respectively. Change the Pulse Width of the reset signal to 25n. The Þnal test-
bench should look similar to Figure 4. Save the design as a new design by going to Design->Save As, 
and renaming the output Þle to something like Ôproj4_Þnal_testÕ. Close the present schematic window 
and open the Ôproj4_Þnal_testÕ schematic.

4. Invoke Analog Design Environment and perform SPICE simulation. Make sure that the cellview 
Ôanalog_extractedÕ comes Þrst before ÔschematicÕ in the Switch View List Þeld when you go to Setup-
>Environment. Even though your top-level module doesnÕt have an Ôanalog_extractedÕ cellview, the 
lower modules do. This means that this simulation will take into account intra-module parasitics but 
not inter-module ones. Compare the adder waveform outputs of the SPICE simulation with the ones 
predicted by your Verilog simulation.

 

8. Placement and Routing of the top-le vel design 
(result:  Physical la yout of the top-le vel design)

 

1. The next step is to create the physical layout of the top-level design. Open the Ôproj4_ÞnalÕ schematic. 
Invoke the layout tool by going to Tools->Design Synthesis->Layout XL. This invokes Virtuoso-XL, 
which is a more powerful form of the Virtuoso Layout tool that you have used previously. Choose the 
default options in any new window that pops-up. The main thing that this accomplishes is that it opens 
a Virtuoso XL Layout window that is linked to your schematic. It is aware of your design and all the 
connections required to Þnish it. 

2. We now need to instantiate all the three modules included in the design. Although this could be done in 
a single automatic step, it introduces some problems that are a bit difÞcult to explain how to solve. An 
easier approach is to instantiate each module one by one. Go to Create->Pick from Schematic. After a 

 

Figure 4:  Testbenc h for design Ôproj4_ÞnalÕ.   
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new window pops up, click on one of the modules in the schematic and after clicking, click on any 
point inside the layout window. This should instantiate a layout of that module in the Virtuoso Layout 
window. Repeat this step for all three modules. (Note that at this point, the zoom commands like Ôctrl-
ZÕ, Ôshift-ZÕ and ÔfÕ will really become useful. Also, if all you see of your layout is a red box and a title, 
you are seeing its black-box version. Press Ôshift-fÕ to show every layer in the layout, and Ôctrl-fÕ to go 
back to showing only the box outline).

3. Since we will not really be concerned about any opti-
mizations here, you are free to place the three mod-
ules anyway you want. It is probably best to use as 
little area as possible, though. An example ßoorplan is 
shown in Figure 5. The white crosshair indicates the 
origin, and doesnÕt really affect the circuit functional-
ity. 

4. The next step is to automatically generate the inter-
face pins that will allow signals to go in and out of 
this design. The simplest way to do this is to go to 
Connectivity->Update->Components and Nets. The 
window ÔLayout Generation OptionsÕ is shown in 
Figure 6. In this window, make sure that the 
ÔLayer/MasterÕ option is set to metal2-dg, and that the 
ÔcreateÕ option is enabled, then click on ÔApplyÕ. This 
tells Virtuoso to use this template for all the I/O pins 
in the list. Click on OK then press ÔfÕ to show the 
entire layout. Aside from creating the metal shapes for 
the pins, the previous step also creates a purple rect-
angle in the Ôprbound-dgÕ layer. This layer doesnÕt 
have any physical signiÞcance, and only serves to 
demarcate the boundary of the layout for user use. 

5. It will be hard to see the pins you created. Go to Edit-
>Select->Select All (shortcut: Ôctrl-aÕ). This should 
give you some clue to where the pins were Þrst instan-
tiated by default, although locating them doesnÕt 
really matter since we will be placing them automati-
cally.

 

Figure 6:  Layout Generation Options windo w used 
to automaticall y generate the design input and out-
put pins.    

 

Figure 5:  Sample ß oorplan f or the Ôproj4_ÞnalÕ layout.    
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6. By using the move command, place the three modules in the mid-
dle of the purple prbound-dg rectangle. Make sure that all of the 
modules are inside the boundary. We now automatically place the 
pins by going to Place->Pin Placement. Select all of the pins in 
the ÔPin NameÕ column, and then in the ÔEdgeÕ Þeld pulldown 
menu below, choose ÔBottomÕ then click on ÔApplyÕ. This auto-
matically places all the pins along the bottom edge of the 
prbound-dg rectangle. Close the pin placement window and ver-
ify that the pins have been placed by zooming in along the bot-
tom edge. 

7. After placing the individual modules and pins, we now proceed 
to the Þnal routing. (Note: The next steps will work only if you 
executed icfb after running the scripts Ô/soft-
ware/cadence/cadence ncsu50Õ *AND* Ô/soft-
ware/cadence/cadence iccÕ. The ÔiccÕ package makes available 
the parts of the Cadence CAD suite that we will be using for rout-
ing). Go to Route->Export to Router. A window should pop-up 
that looks like the one shown in Figure 7. The only things that 
have to be modiÞed here are the rules Þle and the router deÞni-
tion. Make sure that the ÔUse Rules FileÕ option is enabled and 
locate the Ôenee302h_tsmc03.rulÕ Þle in the working directory. 
This rules Þle enables Cadence to correctly transfer Virtuoso 
Layout information to another form that is used by the router 
software. Lastly, make sure that the ÔCadence chip assembly 
routerÕ option is enabled instead of ÔVirtuoso custom routerÕ. (We 
donÕt have the license to use VCR). Click on OK. This should 
open the Cadence Chip Assembly Router program and should 
look like the window shown in Figure 8. 

8. The Þrst thing that needs to be done is to tell CCAR which metal 
layers it could use. Click on the ÔLayersÕ button in the left toolbar 
and change the metal layer deÞnitions as shown in Figure 9 (origi-
nally, every layer is disabled. RedeÞne it such that it is alternately 
horizontal then vertical).

9. After redeÞning the layers, we can now proceed directly with rout-
ing. Go to Autoroute->Detail Route->Detail Router. The AutoR-
oute window should pop up. Accept the defaults by clicking on 
OK. This step should start the router and you should see the incre-
mental results onscreen as the router makes the connections one by 
one. 

10. The next step is to remove so-called ÒnotchesÓ in the wires that are 
going to cause a lot of DRC errors if left unchecked. Go to Rules-
>Setup and Check. The window shown in Figure 10. Enable the 
Ôsame netÕ option and then click on ÔSetup and CheckÕ and then 
click on OK. Lastly, go to Autoroute->Post Route->Remove 
Notches. This should automatically remove these artifacts.

11. The design should be Þnished at this point. For a more involved design ßow that has more constraints, 
additional steps like clean-up routing and other procedures have to be performed. But for this initial 
foray into the design ßow, this is as far as we will go in using CCAR.

12. The last step is to import the results back into Virtuoso-XL. Go to File->Write->Session. Accept the 
defaults by clicking on OK. (If prompted to overwrite *.ses Þle, just say yes). You should now see that 

 

Figure 7:  Expor t to Router windo w 
used to e xpor t the la yout inf orma-
tion to the r outer software .   

 

Figure 9:  Updating the metal la yer 
usage deÞnition.    
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Figure 8:  Initial state of the Cadence Chip Assemb ly Router after in voked fr om within Vir tuoso-XL.    

 

Figure 10:  Setup/Chec k Rules that enab le elimination of metal ÒnotchesÓ.   
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the layout inside VXL has been updated. We can now close the CCAR window. Quit the program 
(choose not to write the *.did Þle when prompted). Save your design. The layout should now look sim-
ilar to the one shown in Figure 11.

 

9. DRC, LVS and SPICE veriÞ cation of top-le vel design 
(result:  veriÞed ph ysical la yout of the entire design)

 

1. The next step is to verify the Þnal routed layout. Go to Verify->DRC to run a DRC check. If any errors 
are found, go to Verify->Find Marker, and make sure that the ÔZoom to MarkersÕ option is enabled so 
that you will be shown exactly where the errors occur. With the help of the explanation shown in 
another window, Þx all the mistakes. This can be done either by stretching existing shapes or drawing 
new ones in the proper layers.

2. After the design has no DRC errors, we can now perform circuit extraction. Go to Verify->Extract and 
make sure that the ÔExtract_parasitic_capsÕ switch is listed. Click on OK. This creates the ÔextractedÕ 
cellview that contains the circuit transistor-level netlist along with any parasitics.

3. Perform an LVS check by opening the ÔschematicÕ and ÔextractedÕ cellview windows and going to 
Extract->LVS in the ÔextractedÕ cellview window. ConÞgure the LVS window properly and proceed 
with LVS. After the design is LVS clean, generate the Ôanalog_extractedÕ cellview.

4. The last step is to redo the SPICE simulation. This time, since the top-level module in the design has 
an Ôanalog_extractedÕ cellview that contains all the parasitics (including both intra-module and inter-
module), this will have precedence and it will be the one used in the simulation. Try and compare the 
Þnal waveforms with the waveforms before the inter-module parasitics were considered. Because the 
Þnal layout as shown here is so inefÞcient in terms of area, long wires were needed to interconnect the 
modules and pins, resulting in unusually long wiring capacitances. This will make the Þnal output 
waveforms look signiÞcantly more degraded compared to the previous simulation.

5. The SPICE waveforms of the output are shown in Figure 12. The Þrst four outputs are marked with red 
rectangles with their hexadecimal value shown on top. This is veriÞed to be exactly the same as the 
logic output of the Verilog testbench. (Note that the LSB is not shown here because of lack of space)

 

Figure 11:  The design after Þ nal r outing.    



 
ENEE 302H: Digital Electr onics 

 
Ñ

 
 Project 4:  Cadence Tools,  par t 3 (10%)

11

 

10. Done!

 

Congratulations! YouÕve Þnished your initial foray into digital design. It is very important to real-
ize that almost all of the steps here were unconcerned with optimizing the design. They only serve
to give you some exposure to the basics of the design ßow. Understanding everything that is
required to optimize circuits will require more knowledge that is not expected from undergradu-
ates at this level.

Our Þnal result is the veriÞed physical layout of a random number generator plus adder system. If
we had wanted to fabricate this design, the only step needed (again, without optimizing anything),
is to instantiate I/O pads that allow external wires to be bonded to the chip, and then connect our
module properly. This design can then be exported into either a GDS-2 or CIF format that can be
submitted to a chip foundry for fabrication.

Lastly, familiarization with this design ßow now enables you to implement almost any design you
can think of. As long as you have deÞned the functionality of your design in Verilog correctly, this
design ßow will enable you to generate the designÕs physical layout, and as explained in the previ-
ous paragraph, the design is only one step away from tape-out and fabrication. Although we make
it sound as if creating digital ICs is almost easy, the bigger challenge is to learn the other aspects
of the design ßow that are concerned not just with the designÕs functionality, but with other met-
rics like performance, chip area, power dissipation, testability, manufacturability, and a bunch of
other important metrics.

 

Figure 12:  Output SPICE wa veforms f or the top-le vel design inc luding intra and inter module parasitic capacitances.    


